Worldline Sips2 module for Magento 2

400,00 € 400.0 EUR

400,00 €

Worldline SIPS2 module for Magento2

This module will allow your customers to pay via Worldline SIPS2 payment method including (VISA, Mastercard, American express ...). 

The module now supports SIPS 2.0 API since SIPS 1.0 API will no longer be supported by worldline by the end of December 2021 (more info). None the less merchants who have migrated from sips v 1.0  API through the configuration menu. Also along with the module free installation and/or  configuration by our team is offered (cost included in the module price)., the module is also refundable if not satisfied.
Supported magento versions: Magento 2.X

sips2-migration

Instructions for SIPS v2.0

As display on the screenshot above, merchant using the v 2.0 of the API can discard the instructions for v1.0 setup. They will only require the merchant_id and the secret_key associated to have the module working. Also, special attention should be paid to the SIPS version setting in the backoffice:

  • SIPS 2.0 (migration) for merchants who have migrated from v 1.0 to v 2.0 interface keeping their merchant_id
  • SIPS 2.0 (transacationReference) for merchants whose subscription begun under the v 2.0 premises and the shop is in transactionReference mode
  • SIPS 2.0 (auto) for merchants whose subscription begun directly the v 2.0 premises and whose TransactionReference should be generated by WL sips API.

Here's the list of credit cards that you can use on test environment.

Installation

php bin/magento module:enable Madit_Sips2
php bin/magento setup:upgrade
php bin/magento cache:flush

The module can be configured underStores>Configuration>Sales>Payment methods>MADIT

Need help? Don't hesitate fill this form



Checkout preview

sips2-migration


Worldline payment page

sips2-migration